Virtual Visit Tariffs - Update
Incident Report for LibreMD
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 19:36 CDT
Monitoring
LibreMD has pushed the new Virtual Visit Tariffs to our EMR and they are now available in billing. For more information about the new tariffs, consult this document from Doctors Manitoba: https://doctorsmanitoba.ca/wp-content/uploads/2020/03/Virtual-Visit-Tariffs.pdf

Please contact support if you have any questions.
Posted Mar 16, 2020 - 19:35 CDT
Investigating
LibreMD is aware of the new Virtual Visit Tariffs being introduced in response to COVID-19. We are currently awaiting further guidance from Manitoba Health regarding the specific tariffs. We are also making any needed modifications to our underlying billing fee system to ensure we will be able to immediately support these new tariffs. Once we receive full details on the tariffs, LibreMD has the ability to enable the new tariffs without requiring a system update.

We will continue to send updates on this situation. Please contact Support if you have any questions.
Posted Mar 16, 2020 - 10:25 CDT
This incident affected: LibreMD EMR.